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1 Introduction
“… the abundance of information will be such that either you have reached such a level of
maturity that you are able to be your own filter, or you will desperately need a filter… some
professional filter.”
Umberto Eco, “A Conversation on Information”
(an interview by Patrick Coppock1, February, 1995)

SCAN (Smart Content Aggregation and Navigation) is a semantic desktop content aggregator. It integrates navigation, search, tagging, text analysis and metadata functions to provide new user experience of
personal document management.
SCAN goal is to be a solution for major problems of personal content organization and findability in information overload age. It aggregates information flows from different sources into a single searchable
and explorable semantic space for fast finding and navigating the documents and other content items.
SCAN is a desktop cross-platform application written in Java. It is designed to be a flexible component
framework, easily configurable for specific user needs and extensible by integration the plugins for new
document locations and formats, as well as the user interface add-ons.

1.1 SCAN integrated approach
SCAN approach is based on an idea that information overload is a complex of problems and no single
magic bullet exists to solve them effectively. Thus, there is a synthesis of few different techniques aimed
at specific aspects of the problem.

Content aggregation
SCAN erases the boundaries put on information by different storage systems. It links the information
items from multiple sources and of different formats into a seamless digital library, where they can be
categorized, annotated, navigated and searched by a uniform way. This provides a homogeneous searchable and explorable semantic information space where files, web-pages, emails, other content items are
equal documents organized by their natural semantic properties.
The component architecture makes the technology agnostic of specific types of sources (local or network
file systems, web-sites etc.) and of the document formats (MS Office, PDF, HTML …). A number of
those types of sources and formats can be supported via integration of the components for a specific business application.

Tagging
Tagging is the easiest and intuitive way of information modeling and organization of the documents collection similarly to the popular services like del.icio.us or Flickr. Tags are keywords or labels freely attached to the items to identify them for quick navigation and finding. All tags together form a taxonomy
representing the semantics of the documents collection. The taxonomy can be viewed as a “tags cloud”
for navigating through the documents.

Text analysis and concept extraction
SCAN brings the power of automated text mining and natural language processing to discover document
semantics by extracting the valuable terms and their patterns from the document content. It makes possible to identify what the document is about and how it relates to others.
1

http://carbon.cudenver.edu/~mryder/itc_data/eco/eco.html

5

SCAN Desktop: Smart Content Aggregation and Navigation. Version 1.3

Text analysis greatly simplifies the process of tagging. It helps a user to pick the most relevant terms
identifying a document and assign them as the document tags. It makes the manual document tagging as
simple as selecting the tags from the suggested candidates. Also, a user can entrust the process of tagging
entirely to the system, so that the documents would be tagged automatically with the relevant terms.
Text analysis is also underlying the advanced semantic search functionality like finding the documents by
similarity (pattern search) and associative guided search based on system suggestions.

Metadata and facet navigation
SCAN provides a rich set of metadata properties associated with the documents, including document title,
description/annotation, author, creation date and others. The properties are set automatically on a document adding and can be quickly edited later.
Metadata properties can be used in the structured search to find the documents matching specified criteria. In addition, some properties (e.g., author or creation date) may be used as navigation facets to browse
the documents collection.

Search
Content of documents is indexed for search – either unstructured full-text search or more complex, structured queries both on text and metadata properties. It is possible to save the search queries for repeatable
use, thus creating the dynamically populated sets of the documents grouped by specified criteria.
Advanced semantic search techniques are driven by text analysis functionality. After any search request
is performed, the results are analyzed to build a “see also” terms list for associative search. It provides
step-by-step exploration of an area of interest following the system recommendations. Pattern search explores semantic compatibilities between different documents and allows to find the documents conceptually similar to a subject of a given one.

1.2 Terminology
Document
An every single content item: a file, a web-page, an email message etc.
Property
A field of a document containing data of a specific type. A text, a title, an author name and a creation date are the examples of different document properties. Some properties (e.g, a title) can be
edited by the SCAN user interface, while others (e.g a text or a last modification date) are set
from original document source and are not editable.
Repository
An aggregated collection of documents managed by SCAN.
Location
A physical source of documents: a directory, a web-site, a mail folder etc. The documents are
added to the repository via locations containing them.
Tag
A keyword, or a text label assigned to a document to identify its topic. The concept of tags is a
cornerstone of SCAN navigation system.
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Autotagging
An automated process of extraction of the important words (concepts) from a document content
and assigning them as document tags.
Tag auto-population
An automated process of finding the documents relevant to a given tag and assigning it to those
documents.
Facet
A document property, enumerated values of which are used for navigation through the repository.
Examples of facet properties are the Author and Creation date. Together with tags, facets are the
key items of SCAN navigation system.
Plugin
An extension module, providing some additional functionality to SCAN. New document formats,
new location types and user interface extensions are added to SCAN via the mechanism of plugins.
Tab
One of the panels in the main area of SCAN application screen, switched with the buttons at the
left vertical bar. The default tabs represent main user activities on working with the repository
(“Browse”, “Search” and “Tags”). The plugin modules can install additional tabs.

1.3 Feedback and support
1.3.1 Community tools
Check the SCAN community area on SourceForge.NET web-site:
•

http://sourceforge.net/projects/scan/

Please ask your questions and share your opinion about SCAN at the community discussion forum:
•

http://sourceforge.net/forum/forum.php?forum_id=665371

To report a bug, please use the community Bug tracker:
•

http://sourceforge.net/tracker/?group_id=189359&atid=929010

Your ideas on future development are welcomed at the Feature request tracker:
•

http://sourceforge.net/tracker/?group_id=189359&atid=929013

1.3.2 Commercial support
ViceVersa Technologies (http://www.viceversatech.com), a company behind the SCAN development,
provides high-quality support services for customers, including:
•

Professional technical support directly from software engineers

•

Hot bugfixes and on-demand custom releases

•

Development of custom proprietary components for integration with the elements of customer IT
infrastructure (such as document management systems and databases) to build the customized
business-specific solutions.

Contact ViceVersa: info@viceversatech.com.
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2 Installation and running
2.1 Prerequisites
You need Sun Java 2 Runtime Environment (JRE) version 5.0 (or higher) installed in your system before
you can use SCAN. You can download a free copy of JRE for your platform from
http://java.sun.com/javase/downloads/.
SCAN is a cross-platform software, independent from specific computer platform and operating system.
At the moment, the following platforms are tested and fully supported:
•

MS Windows 2000/XP/Vista

•

GNU Linux

2.2 SCAN installation
2.2.1 MS Windows
To install SCAN in MS Windows operating system, execute scan-1.*.exe automated installer and follow instructions on the screen.
After installation is completed, you can run SCAN via the Start menu (new SCAN section will be created)
or using a shortcut on your desktop.

2.2.2 Cross-platform install
To install SCAN on other platforms (or if you cannot use the Windows installer by some reasons), use the
cross-platform distribution (a compressed ZIP archive file). Use any unzip utility to unpack the distribution archive into a directory of your choice.
After unpacking the archive, you should see the following directory structure:
1 scan-**
0 conf
0 lib
0 plugins
2 LICENSE
2 README
2 scan.bat
2 scan-launcher.jar
2 scan.sh

The start-up scripts for Windows (scan.bat) and UNIX systems (scan.sh) are provided for running
SCAN.
Note: On a UNIX-based system, you may have to set executable permissions for the shell script:
$ cd scan-**
$ chmod 755 ./scan.sh

It is possible also to run SCAN using executable scan-launcher.jar file. Generally, it is enough to double-click this file in your file manager to get SCAN started. If it doesn’t work, check your system file associations or execute SCAN launcher from a console:
$ cd scan-**
$ java -jar scan-launcher.jar
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2.3 Plugins installation
In the “Plugins” section of SCAN web-site1 you can find a number of software components (plugins) for
many additional features. Plugins are installed by users choice to extend SCAN functionality.
All changes of plugins are activated after restarting SCAN.

2.3.1 Manual plugin installation
To install a plugin manually, download it from SCAN download area 2 and unpack the downloaded ZIP
file into the plugins/ subdirectory of your SCAN platform installation. The plugin directory must be a
direct subdirectory of the plugins/.
To remove a plugin, delete its directory from plugins/.

2.3.2 Installation using Plugins manager
Since 1.2 version, SCAN is provided with new plugins management framework for easy download, installation, upgrading and removing the plugins within the application.

Illustration 1: Plugins Manager dialog

To open the Plugins Manager window, proceed to the Tools → Manage plugins… menu.
The Plugins manager shows all plugins available to download and install. The plugins are grouped into
categories, represented by dialog tabs.

1
2

•

To download and install a selected plugin, click on Install button.

•

If newer version of an installed plugin is available, click on Upgrade button.

•

To remove a plugin, click on Uninstall button

•

To update plugins information, click on Check for updates button.

http://scan.sourceforge.net/?page_id=6
https://sourceforge.net/projects/scan/files
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2.4 Uninstall SCAN
2.4.1 MS Windows
To remove SCAN from your MS Windows system, select Uninstall SCAN in SCAN section of the Start
menu and follows instructions on the screen.

2.4.2 Cross-platform install
To remove SCAN, installed from a cross-platform ZIP file distribution, delete the folder where you have
unpacked the file.

2.4.3 Delete the repository and data files
The uninstall procedure preserves repository files, configurations, cache and other data files, used by
SCAN. This allows to restore the program environment in next SCAN installation (e.g., after version upgrade).
To remove the SCAN data, delete the directory where it is located. You can find the actual path of this directory in the Repository path field of SCAN configuration dialog (Tools→Configure...).
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3 Repository Management
The cornerstone of the SCAN architecture is the documents repository. The repository is a centralized
collection to keep records on the documents independently from their physical locations. A user can
browse or search the documents in the repository and open them from their original locations with the
suitable external applications.
The repository aggregates content from different sources. The folders in the local or network filesystems
are used as the document sources by default. A number of other types of sources are available with the installed plugins: web syndication feeds, mailboxes, del.icio.us bookmarks and others.
Adding documents to the repository is automated. A user only need to point SCAN to a location she
wants to add and the application will find and add every document from there. Added locations are monitored for changes (new, modified or deleted documents) to keep the repository up-to-date.
The repository keeps records on user’s documents with rich set of metadata properties: title, description,
original location, author, creation date etc. The metadata properties associated with the documents are set
automatically on a document adding and can be quickly edited by a user. Their values can be used in
search queries to find the documents matching the specified criteria.
A full-text search engine is integrated with the repository. When new documents are added to the repository, their content is extracted and indexed for search.
The repository is independent of the specific document formats. The number of popular document formats is supported either natively or via the plugins, including HTML, PDF, OpenOffice ODF, MS Office
documents, plain text files and email messages.
Repository management operations are available in the Browse application panel. The panel contains the
list of all locations in the repository which can be browsed with the documents list of this panel.

Illustration 2: Locations list

Repository management operations are accessed via Collection menu items. They are duplicated with the
buttons on the locations list toolbar and with the context menu.

3.1 Adding a location to the repository
When new location is added, SCAN gets the documents found in this location by a specific location
provider. Location provider is a part of a Location type plugin, which knows how to extract the documents from a specific location type. The Directory location provider is built-in and does not need a
plugin to be installed.
The provider for new location is selected in Collection → Add documents submenu.
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Content and metadata of the documents are extracted using an appropriate parser which depends on a
document format. A format of an each document is generally determined by a filename (URL) pattern.
The default (built-in) document formats are:
Filename pattern

Document format

MIME-type

*.txt (or no extension)

Plain text document

text/plain

*.html, *.htm, *.xhtml

(X)HTML document

text/html

*.xml

XML document

text/xml

Table 1: Built-in document types

Installed Document Type plugins register new filename patterns for their own document formats. For instance, after installing the PDF plugin, all “*.pdf” files will be recognized for adding to the repository using the parser of this plugin. If no parser is found for a specific filename pattern, the file will be skipped
(ignored).
Adding the documents to the repository is a time- and resource-consuming operation, and it is thus performed in background mode.

3.1.1 Adding a directory location
To add new directory location, select Collection → Add documents → Add directory… menu item.

Illustration 3: "Add new directory location" dialog
•

Select a directory with the Browse button or enter the valid directory path into the Base directory
field.

•

The value of Location title will be set automatically to the base directory name. You can change it
as you wish.

•

Select Include subdirectories checkbox to add the documents recursively from all subdirectories.

•

Optionally select a language of documents in this location and set other location options (see 3.2
Common location options).

•

Click Add button to start adding the documents.

3.2 Common location options
The location options described in this chapter are independent from specific location provider and can be
set for any type of location.
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3.2.1 Language
The Language selector of the location dialog box allows to set a language for the documents in the location. Language settings affect the way the documents are indexed – specifically a language-specific algorithm of stemming the words and stop-word filtering.
By default, the language is set to one defined in the global configuration dialog (see 3.5). With the Language selector of the location dialog box you can redefine it on per-location basis.
Select Mixed (autodetect) option if the location contains documents written in multiply languages. In this
case, SCAN will try to identify the language of each individual document automatically (may slow down
the indexing process).

3.2.2 URI filter
URI filter allows to define custom rules about which documents should be processed and which ones
should be skipped in this location, by defining two URI patterns:

Illustration 4: URI Filter tab of Location dialog
•

Leave the Include all known document types checkbox selected to include all documents allowed
by installed document type plugins. For instance, if PDF plugin is installed, all documents with
“.pdf” filename extension will be processed, etc.

•

Unselect the Include all known document types checkbox to set a custom inclusion rule in or include only field. If the inclusion rule is set, only documents matching this rule will be processed.

•

In the Exclude field you can define a rule to exclude the specific documents from the location. All
documents matching this rule will be skipped.

Inclusion and exclusion rules are defined as regular expressions1 of the file names or URLs. Examples include:
- All files with names ending with “.doc” (“.*” denotes any number of characters, the
dot symbol must be escaped by a backslash).

•

.*\.doc

•

.*\\Desktop\\.*

- All files with names containing “\Desktop\” in the middle (the backslashes

must be escaped).
•
•

http:\/\/www.* - All URLs starting with “http://www”.
.*\.doc | .*\\Desktop\\.* | http:\/\/www.* - Combination

of these three rules (the “|”

character acts as “OR” operator).

1

http://www.javaworld.com/javaworld/jw-07-2001/jw-0713-regex.html
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3.2.3 Custom update interval

Illustration 5: Settings tab of Location dialog

By default, all locations are checked for updates in a time interval defined in global application preferences (3.4.4 Setting up update automation). On the Settings tab of a location dialog you can define a custom update period for specific location. To enable it, select Use a custom update interval checkbox and set
the interval (in minutes or hours). Zero value will disable the automatic update for this location.

3.2.4 Autotagging
If Apply autotagging for new documents options is set, all new documents of this location will be automatically tagged after adding to the repository. By clicking Autotagging options button, you can call the dialog to change default tagging options for this location (see 4.6).

3.3 Manage locations
3.3.1 Edit location properties
To edit the properties of a specific location, select in the locations list and select Collection → Edit location
menu item.
Note that some basic properties (such as a base directory etc.) are not editable. To change these properties
you have to re-create the location.

3.3.2 Remove a location
To remove a location from the repository, select it in the locations list and select Collection → Remove location menu item.
The documents will be removed from the repository only. The operation does not affect any original files.

3.3.3 Autotag a location
To apply autotagging to all documents of a specific location, select in the locations list and select Collection → Autotag location... menu item.
Set the autotagging options in the appeared dialog box (see 4.6) and press Ok to start autotagging process.

3.4 Update the repository
Updating is an operation of synchronizing the repository with actual state of the documents. It checks the
locations for new, modified or deleted documents:
14
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•

New documents will be added to the repository

•

Modified documents will be re-indexed and updated in the repository

•

Deleted documents (which are no longer exist in their original locations) will be removed from
the repository

Updating is started in background mode either manually, or automatically (after a specified time interval
is passed).

3.4.1 Updating a single location manually
To check a single location for new, modified or deleted documents and update it in the repository, select
the location in the locations list and select Collection → Update location menu item.

3.4.2 Rescanning a location
While usual update checks a location incrementally (the unmodified documents are ignored), rescanning
performs full re-indexing of all documents in the location. It has an effect similar to re-creating the location and may be needed, e.g., after changing the global indexing options (3.5).
To rescan a location, select it in the locations list and select Collection → Rescan location menu item.

3.4.3 Updating the whole repository
To update all locations in the repository, select Collection → Update all menu item.

3.4.4 Setting up update automation
Updating the collection can be performed manually (3.4.1, 3.4.3) or automatically, ۛin a specified time interval. To configure automated updating, open the system Configuration dialog (Tools → Configure...).

Illustration 6: Configuration dialog: Update collection
•

To set the global update interval, select Use interval updating checkbox and enter an interval in
minutes or hours. To disable automatic updates, unselect this checkbox. Update interval can also
be set for a specific location individually (see 3.2.3).

•

If Update on start checkbox is selected, the collection will be updated every time when SCAN is
started.

3.5 Indexing options
To configure document indexing, open the system Configuration dialog (Tools → Configure...).

Illustration 7: Configuration dialog: Indexing options

15

SCAN Desktop: Smart Content Aggregation and Navigation. Version 1.3
Default language

selector defines a default language of the repository. The default language has two pur-

poses:
•

A language used by default for new locations. Location-specific language settings (3.2.1) override this.

•

A language used for parsing the search queries

It is recommended to set this parameter to a primary language of your document collection. If it is set to
Mixed (autodetect), SCAN will try to identify the language in every case.
option enables the lexical analysis of the documents content. If this option is set, the
stems of the words will be extracted and indexed instead of the words themselves. For instance, the words
“work”, “worker” and “working” will be indexed as a single term “work”, so that the search for this term
would return documents containing all variations of the lexeme “work”.
Apply stemming

If Filter stopwords option is turned on, the words listed as the “stopwords” for a selected language will be
excluded from the index. Stopword lists are used to filter so-called “common words” (such as “the”,
“and”, “this” etc. in English) out of indexing, thus improving search quality and efficiency. Lists of stopwords for each language are available as the plain-text files in /conf/stopwords subdirectory of the
SCAN installation.
Note that changes of the indexing options will affect newly indexed documents only. To apply changes to
existing documents, rescan (3.4.2) or re-create a location.
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4 Working with documents
4.1 The documents list
The documents list contains the documents of a selected location, or the results of a navigational or
search action. The list is located at the right (wide) column of SCAN tabs (and may also be opened in a
separate window).
The list can be viewed in two modes:
•

Detailed view (default)
Displays the list as a table with document metadata properties as the columns

•

List view
Displays a single-column list with brief document info.

To switch between the view modes, use View → View mode menu or

buttons on the list toolbar.

The documents are selected by clicking an item in the list. To select multiple documents, click them in
the list while holding the Ctrl key. To select multiple documents in a continuous range, select the first
item and then the last item while holding the Shift key. To select all documents of the list, choose Select
→ Select all menu item or press Ctrl+A. To clear the selection, choose Select → Select none menu item
(Ctrl+D).
All operations with individual documents or selections are performed in the Document menu. These
menu items are duplicated with buttons on the documents list toolbar and also in the documents list context menu.

4.1.1 Customize the detailed view
The detailed view can be customized by choosing the document properties to display as the table columns
in View → Columns menu. This menu can be called also by right-clicking a column header.
To re-order the columns of the detailed view, drag the column headers. Change the columns' width by
dragging the header edges.

4.1.2 Sort the list
To sort the documents list, select a document property in View → Sort by menu. The documents will be
ordered by values of the selected property. Alternatively, in the Detailed view mode, you can click on a
property column header (repeatable clicks on the same header change the sorting order).
To sort the list in ascending order, select View → Sort by → Ascending order option.
option means that the documents are ordered by relevancy to the query (in
the case of a search result) or listed in no specific order (in all other cases).
View → Sort by →No sorting

4.1.3 Filter the list
Filter search panel on the right side of the documents list toolbar allow to restrict the list content by the
documents that match a specified search query:

Illustration 8: Filter search panel

To filter the documents list, enter a query string into the text field and press

button.
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To select the document properties to apply the filter to, press
pop-up menu box.
To clear the text field and cancel the filter, press

button and select the properties in a

button.

The query string for filtering may use special query expression syntax (see Appendix A.).

4.2 Open a document
Documents from the documents list can be opened with an external application for viewing or editing. It
is possible to set multiple applications for every document type and select which one will be used by default.
To open a document with a default application, double-click it in the documents list or select it and
choose Document → Open document menu item.
On MS Windows and Mac OS X platforms, SCAN uses the default system file associations to identify an
application to open a document. On other types of desktops (or if this method fails otherwise), you will
be asked to set an application before opening a first document of a given type (4.2.1).

4.2.1 Open a document with specific external application
To open a selected document with an external application, already defined for this document type, choose
it in Document → Open document with menu.
To define new application for a given document type and open the document with it, select Document →
Open document with → Select program… menu item.

Illustration 9: "Select program" dialog

•

In the Program file field enter full path to the executable program file or use Browse button to find
and select the file.

•

In the Command line options enter additional command line arguments of the program, if needed.
If this field is empty, only document path (URL) will be passed to the program. Alternatively,
you can define the program arguments line, using double dollar characters ( $$) as a placeholder
for real document path. You may need to refer to the program documentation on its command
line syntax.

•

Select Default application for this documents type checkbox if this application should be used by
default for Open document action (if more than one applications are defined for this document
type).

As soon as the application is set, it will be added to Document → Open document with menu and available
for all documents of the same type. Repeating this operation, you can define as many applications as you
wish.
18

SCAN Desktop: Smart Content Aggregation and Navigation. Version 1.3

4.3 Edit document properties
4.3.1 Quick edit in the detailed view mode
To edit a property value of a document in the detailed view mode, select a document and click on a table
cell of the property to edit the value. Select another document or press Enter when editing is done.
Press Esc in the edit mode to cancel editing and discard the changes.
Note that some properties are not editable.

4.3.2 Document properties dialog box
To edit the document properties in the dialog box, choose Document → Edit document properties menu
item.

Illustration 10: Document properties dialog box

The General tab of the dialog box contains some most common metadata properties to view and edit:
•

Title

The document title
•

Description

A description of what the document is about
•

Tags

A space-separated list of the document tags. You can edit the tags in the text field, or press Select
to call the Edit tags dialog (see 4.5)
•

Author

A document author. Enter the author name or select an existing author in the combobox.
On the Notes tab of the dialog box you can edit the document notes (see 4.4)
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The Details tab contains a detailed table view of all metadata properties of this document. You can edit
those marked with “*”.
To assign a property value for a number of documents at once, select multiple documents and choose
Document → Edit document properties. In the dialog box, fill the fields for the properties you want to assign the values to. For empty fields, the original values will be preserved in the documents.
Press Ok after editing is done to close the dialog box and apply changes.

4.4 Edit document notes
A text note can be attached to a document to describe and annotate it. The “Notes” property differs from
others as SCAN makes no attempt to fill it automatically at indexing stage (it is completely user-edited)
and provides a special user interface to view and edit it.
To view and edit the document notes, select the document in the list and choose Document → Edit document notes menu item. Then, edit the text note in a pop-up dialog box and press Ok.
Alternatively, the notes can be edited:
•

On the Notes tab of the document properties dialog box (see 4.3.2).

•

By quick editing of the “Notes” property in the Detailed view mode (see 4.3.1) .

4.5 Edit document tags
Tags are keywords or text labels freely associated with the documents in the repository to provide tag
navigation facet. There is no limits on a number of tags assigned to a single document.
The tags can contain letters, numbers and punctuation characters, except for quote marks and spaces.
Tags are case-insensitive, so that the tags “cats”, “Cats” and “CATS” are interpreted as the same tag.
To edit the document tags, select a document and choose Document → Edit document tags... menu item.
The “Edit tags” dialog box will appear:

Illustration 11: Edit tags dialog box
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Enter the tags into the Tags text field, separating individual tags with spaces, or select the tags from the
lists below the field:
list contains the tags already assigned to other documents. An item size indicates a
number of documents a given tag is assigned to.

•

Existing tags

•

Suggested tags

list contains the words, recommended by a tag suggestion algorithm. If a word is
an existing tag, it’s marked with a bold font. An item size indicates relevancy of a given term to
the document. You can adjust the length of the list with the Less terms ↔ More terms slider.

Alternatively, the document tags can be edited:
•

Via the Document properties dialog box (see 4.3.2)

•

By quick editing of the “Tags” property in the Detailed view mode (see 4.3.1) .

To edit tags of multiple documents at once, select the documents and choose Document → Edit document
tags... menu. Select Preserve existing tags checkbox to add tags from the dialog box to existing tags of the
selected documents. Otherwise, tags from the dialog box will replace tags of those documents.

4.6 Documents autotagging
Autotagging is a process of automated assigning the relevant tags to documents. Autotagging can be applied to all documents of a specific location (see 3.2.4, 3.3.3) or to individual documents selected in the
document list.
To autotag the selected documents, choose Document → Autotagging... menu item and set autotagging options in a dialog box:

Illustration 12: Autotagging options
•

Set a desired number of tags to be assigned for each document with the Tags per document slider.

•

Select Preserve existing tags checkbox to add new tags to existing ones. If this option is not set,
new tags will replace all tags assigned to the documents before.

•

Selected Do not create new tags checkbox will cause selection of tags from the existing tag set
(new tag creation is disabled). Use this option if you want to control your taxonomy manually.
Note that if Do not create new tags option is set, an actual number of tags assigned to some documents may be lesser than specified, or no tags may be assigned at all. It indicates that there are no
existing tags relevant to those documents.

4.6.1 Global autotagging preferences
Depending on size and semantic nature of your document collection, you may want to adjust global parameters to fine-tune the autotagging process and to achieve the best results. These parameters also affect
the tag suggestion algorithm (4.5).
To set up the autotagging parameters, select the Autotagging tab of the global Configuration dialog (Tools
→ Configure...):
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is an autotagging parameter which defines whether the terms extracted from a
document directly must have higher priority than ones picked from a document context (a cluster
of similar documents). High specificity leads to large and granulated taxonomies with small numbers of documents sharing the same tags, while low specificity increases the value of “general”
terms, thus producing lesser tags number but with more documents per single tag.

•

Tags specificity

•

Tags novelty

•

Tags autopopulation relevancy threshold

parameter controls a tendency of autotagging to invent new tags instead of re-using
existing ones. When set to maximum, existing tags takes no priority of new candidates. Otherwise, if everything else is equal, existing tags have more chances to be selected for new documents. Minimal novelty means absolute priority of existing tags.
defines a minimal value of document relevancy required
by Tag autopopulation algorithm (see 5.2.1) to assign the tag.
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5 Navigation and search
5.1 Faceted browsing
“Browse” tab provides the widgets to navigate the documents collection by selecting the values of specific metadata properties (facets). Facet value selection causes navigating to a subset of the documents
matching the specified value.

5.1.1 Path widget

Illustration 13: Path navigation

The path widget provides browsing the documents by paths of the original files or URLs represented as
tree-like structures. Selection of a tree item causes navigation to a subset of documents in the selected
path (including all descendant items).

5.1.2 Author widget

Illustration 14: Authors navigation

The authors widget contains an alphabetically sorted list of all author names found in the “Author” metadata properties of the documents. Selection of an author in the list causes navigation to a subset of documents matching the selected value.
To find a specific author, start typing the name in the text field below the list. The list will be filtered by
an entered value. To clear the text field, press
button.
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5.1.3 Date widget

Illustration 15: Dates navigation

The dates navigation widget contains a calendar to navigate the document repository by dates of document creation. Selection of a year, a month or a day in the calendar causes navigation to a subset of documents created at the selected period.

5.1.4 Language widget

Illustration 16: Languages navigation

The language widget contains a list of all languages of the documents in the repository. To navigate to a
subset of documents with a specific language, select it in the list.

5.2 Tag navigation
“Tags” tab provides navigation through the document repository using tags, assigned to documents (4.5,
4.6). The tags cloud widget in the right panel contains a list of all existing tags, sorted alphabetically. The
size of a list item indicates a number of documents associated with the given tag.
When a tag is selected, the widget automatically highlights the tags related to the selected one. An intensity of a highlighting color indicates a degree of relevancy between the tags.
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Illustration 17: Tag navigation

Selection of a tag causes navigating to the subset of documents, matching the selected tag. To select multiple tags, hold down the Ctrl key. For quick finding and selection of a tag, click inside the tags widget
and start typing.
Tag management operations are accessed via Tag menu items. They are duplicated with the buttons on
the tags widget toolbar and with the context menu.

5.2.1 Populate tags
Tag autopopulation is a process of assigning a given tag to the documents relevant to it. A minimal
threshold for document relevancy is set in the application preferences (see 4.6.1).
To populate a tag, select it and choose Tag → Populate tag menu item.
To populate all tags, choose Tag → Populate all tags menu item.

5.2.2 Delete a tag
To delete a tag from all documents associated with it, select a tag and choose Tag → Delete tag menu
item.

5.3 Search
“Search” tab provides an interface to the full-text and structured property search functions of SCAN. The
search results are displayed in the tab’s document list, sorted by relevancy by default.

5.3.1 Quick search
To perform a quick search, enter a query string into the text field on the “Search” tab and press
or hit Enter key.

button

The quick search queries can use special query syntax (see Appendix A.)
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If no document property is declared with the special syntax, the search is performed over document properties, defined in the “Search in” menu. To change the searchable property set, open this menu by pressing
button and select the properties in a pop-up menu box.

5.3.2 Advanced search
To perform complex, structured search queries, click on Advanced search or
cial visual query constructor:

button. It calls the spe-

Illustration 18: Advanced search dialog

A query contains of one or more search rules, grouped and connected with boolean operators (“And”/
“Or”). “And” connector means that the search results must be relevant to all rules in a group. “Or” connector — that they must be relevant to at least one rule in a group.
Each rule consists of a document property, condition and a test value. Available conditions (predicates)
and their negations are:
(Does not contain)
Searches for any listed term (space-separated). Wildcard characters (? and *, see Appendix A.
Wildcards) are allowed in the terms.

•

Contains

•

Contains phrase (Does not contain phrase)

Searches for an exact phrase (including space characters)
•

Equals to (Does not equal to)

Searches for an exact value of a given data property. Wildcard characters are allowed.
•

After / Before

For date properties, searches for values of dates after or before the given date. On formatting the
date values, see Appendix A. Date search).
To add new rule to the query, click on And... / Or... buttons for an existing rule. To delete a rule, click on
Delete button.
To save a query for repeating use, enter a name for this query in Save search as field.

5.3.3 Saved searches
Advanced search queries, saved for repeatable use, are available in the list on the “Search” tab panel. To
execute a query, double-click it in the list or select it and press
button on the list toolbar.
To edit a saved query before execution, select it in the list and press
To delete a query, select it and press

button.

button.
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5.3.4 Associative search
On each search query, the results are analyzed to identify valuable terms related to the subject of the
query. These words may give you some hints about what to search also on a subject and are suggested for
the next query.
To add a suggested term into the quick search field, press More ‣ button on the search panel and select a
term in the pop-up list.

5.3.5 Finding similar documents
A special type of search is finding a set of documents, conceptually similar to a given one. This allows to
identify a set of documents on a specific subject, taking a known document as a pattern.
This function is available from the documents list (see 4.1). To find the similar documents, select a pattern document in the list and choose Document → Find similar documents... menu item.
The search results are displayed in a new window as a document list, sorted by relevancy to the pattern
document. Moving Less documents ↔ More documents slider, you can adjust the relevancy threshold to
populate the list.
To close the documents list window, press Close button.
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Appendix A.
Search query special syntax
The special query expression syntax allows to perform complex queries like with Advanced search query
constructor (5.3.2). For complete search query syntax refer to the Apache Lucene guide1.
The search is case-insensitive. In addition, if the documents were indexed with the “Apply stemming” option (3.5) and this option is turned on, a query will match any document containing a variation of a word
with a same stem as the query term have. For instance, the query term “constructor” will match the words
“construct”, “constructor”, “construction”, “constructed” etc.

Document properties
To search on specific document properties in the Quick search (5.3.1), use the term prefix in form of a
name of a property and the colon (”:”). For instance, to search the word “wiki” in document titles only,
use the query term:
title:wiki

To search more than one word in the same document property, use parentheses:
author:(John Mary Jane)

This query returns the documents containing either John, Mary or Jane in the “author” property.
The following document properties are available for search:
•
•
•
•
•
•
•
•
•
•
•
•

title - Document title
description - Document description
text - Document text (default)
author - Document author
notes – Document notes
date - Creation date
date_modified - Modification date
url - Full document URL
file - File name
path - File path
size - File size in bytes (for local documents)
language - Document language code (e.g., “en”, “fr”, “de”,

etc)

Note that the set of metadata properties depends on the document type plugins installed. Some plugins
may define additional document properties. To know which properties are available in your actual configuration, open the Details tab of the Document properties dialog (4.3.2). A common rule of using a property name in search queries is to lowercase all letters and replace spaces with underscore characters (e.g.,
“Date modified” ⇒ “date_modified”). The “Tag” property, though exists, is not searchable.
If no property prefix is set, Quick search uses the properties defined in the “Search in” menu (5.3.1).

Phrase search
By default, a query expression containing multiple space-separated terms matches the documents containing any of those terms. For searching for an exact phrase (including the spaces), it must be surrounded
with double quotes:
"Hello, world"
1

http://lucene.apache.org/java/docs/queryparsersyntax.html
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title:"New York"
author:"John Doe"

Wildcards
Wildcards are used to replace one or more characters in a query.
“?” symbol is a single character wildcard. For example, “h?t” matches any of words “hat”, “hit”, “hot”,
but not “heart”.
“*” symbol is a multiple characters' wildcard. For example, “ list*” matches any of words “list”, “listing”, “listen”, “listener”, etc.
Note: You cannot use a * or ? symbol as the first character of a search.

Date search
The values of the date properties (date and date_modified) has the following format:
yyyyMMddHHmmssSSS

Where
•
•
•
•
•
•
•

yyyy - Year (4 digits)
MM – Month: 01...12 (2 digits)
dd - Day 01...31 (2 digits)
HH – Hours: 00...23 (2 digits)
mm – Minutes: 00...59 (2 digits)
ss – Seconds: 00...59 (2 digits)
SSS – Milliseconds: 000...999 (3 digits)

To search on the date properties the wildcards can be used. For example:
date:20090820* (documents, created at August, 20 2009)
date_modified:200707* (documents modified during July, 2007)

It is also possible to search the documents in a range between two dates:
date:[20070715* TO 20070815*] (documents, created between July, 15 and August, 15 2007)
date:[0 TO 2007*] (documents, created not later than 31/12/2007)

Fuzzy and proximity search
Fuzzy queries are used to find the terms similar in spelling to a given word. For a fuzzy search, add the
tilde, "~", symbol at the end of a single term expression:
roam~

(will find documents containing words “roam”, “roams”, “foam”, “road” and alike)

For finding words which are within a specific distance away (proximity search) use the tilde, “ ~” symbol
at the end of a phrase. For example to search for an “oil” and “import” within 10 words of each other in a
document use the search:
“oil import”~10

Boosting a term
In multi-term queries, it’s possible to specify a boost factor of a specific term. A boost factor indicates an
importance of a term in the query, so that the documents matching the boosted terms will have higher relevancy in the search results. To boost a term use the caret, “^” symbol with a boost factor (a number) at
the end of the term you are searching:
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(documents containing an “oil” (or “oil” and “import”) will be 4 times more relevant than
those, containing “import” only).
oil^4 import

Boolean operators
Few term expressions can be combined in a single query through boolean (logic) operators ( OR, AND, +, -,
NOT). By default, if no operator is defined, boolean OR is assumed. For instance:
author:(John Mary Jane) is equivalent to
author:(John OR Mary OR Jane) or
author:John OR author:Mary OR author:Jane

conjunction means that the result may contain at least one of the specified terms (either John, Mary or
Jane).
OR

and NOT operators must contain UPPERCASE letters only. They can also be substituted with the
following symbols:
OR, AND

OR : ||
AND : &&
NOT : !

AND operator
If the terms are combined with AND (&&) operator, all terms must be presented in the search result:
title:oil AND price

Searches the documents that contain “oil” in the title and “price” in the text.

+ operator
“+” prefix indicates a required term. The result must contain the term after “+” symbol:
+oil import price

Searches the documents that contain “oil” and optionally, “import” or “price”.

- operator
“-” prefix indicates a prohibited term. The documents containing this term are excluded from the search
results:
-olive oil

Searches the documents that contain “oil” but not “olive”.

NOT operator
If two terms are combined with NOT operator, the documents that contain the term after “ NOT” are excluded from the search result:
oil NOT olive

Is equivalent to the example above.

Grouping
To group the boolean clauses in complex search queries, parentheses are used. Examples:
(title:oil OR oil) AND price
(author:(John Mary Jane) AND import) NOT date:2007*
(oil AND price) OR (brent AND urals)
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Escaping Special Characters
Some characters are reserved by query syntax and must not be used unescaped:
+ - && || ! ( ) { } [ ] ^ " ~ * ? : \

To escape these character use the backslash, “\” before the character. Examples:
“Washington \(city\)”
“\”Exactly\!\”, he said.”
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Appendix B.
Troubleshooting
If you experience problems with SCAN:
1. Check the messages in the application log window or in a log file (see Logging section below)
2. Check the program debug output in the system console (see Logging section below)
3. Read the “Common issues” section of this appendix
4. If no solution is found and you think the problem is caused by a bug in the application, feel free
to submit a bug report (see 1.3 Feedback and support). Please provide a detailed description of
your problem and attach the console output if possible.

Logging
Log window
To see the warning and error messages in the application log, click on the button in the bottom right corner of the SCAN screen. The log messages window will appear.
To force immediate memory garbage collection, press GC button. It may free some amount of RAM.
To clear the messages window and close it press Clear and close. To close the window without clearing
the messages, press Close.

Console output
To see the full program output while SCAN is running, open the system console window, go to the directory where SCAN is installed and execute the startup script (scan.bat or scan.sh, depending on your
platform).

Logging to a file
To configure file logging, open scan.conf file in the SCAN home directory in a text editor of your
choice and add an entry:
<entry key="scan.logging.file.level">ALL</entry>

Instead of ALL you can specify the minimal level of messages to be written into the file ( CONFIG, INFO,
WARNING or SEVERE).
By default, the log file is named scan.log and located in the SCAN home directory. You can change its
name and location by adding a scan.logging.file.path entry, e.g.:
<entry key="scan.logging.file.path">/var/log/scan.log</entry>
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Common issues
SCAN doesn’t work at all
Make sure Java 5.0 or later from Sun Microsystems1 is installed on your system. Older versions
(1.4 and earlier) and Java implementations from other vendors (e.g., GNU) may not work. To
check the installed Java version, type in the console:
$ java -version

“Tagger: Cannot connect to database ...” error at startup
Indicates that another SCAN process is already running or that a previous session has been halted
unexpectedly (e.g because of a power break). Make sure that SCAN is not already started with
the same repository path. If it is not the case, delete repository/db/.lck file and run SCAN
again.
“Out of memory” error
SCAN may run out of memory limits when parsing very large documents. If it happens, try to increase an amount of RAM available for Java Virtual machine by editing a line in the startup
script, e.g.:
java -Xms256M -Xmx256M

-jar scan-launcher.jar

In the example above, RAM limit is increased up to 256Mb. You can replace it with another reasonable value.
Encrypted PDF files are skipped
The feature is unsupported at the moment.
No PDF file content is indexed
Some PDF files (e.g., scanned from paper) contains images instead of a parseable text. You can
check this – if it’s impossible to copy-paste the text from Adobe Acrobat Reader, it is unlikely
that the file can be processed by SCAN PDF plugin. Probably, non-standard character encodings
may cause this problem as well.
Duplicate document entries
Tags without documents
May be caused by an unexpected break of the application. Run Index maintenance function
(Tools → Configure... → Index Maintenance → Start) to check and fix the repository index.

Backup and restore the repository and settings
It is recommended to backup the repository and configuration files before upgrading the SCAN version.
To make a repository backup, copy the contents of the SCAN home directory. To identify the path to this
directory, look at the Repository path field of SCAN Configuration dialog (Tools → Configure...).
To restore the repository, copy the archived contents back to this directory (check if SCAN is not started
during copying).

1

Http://www.java.com/en/download/
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Appendix C.
Keyboard shortcuts
Shortcut

Action

Enter

Open a document

Ctrl+Enter

Select a program to open a document

Alt+Enter

Edit document properties

F2

Edit a property in a selected cell

F4

Edit document tags

Shift+F4

Edit document notes

F5

Update a selected location

Ctrl+F5

Update all locations

Up / Down

Navigate the document list

Ctrl+Home / Ctrl+End

Go to the top / bottom of the list

Shift+Up / Shift+Down

Select the list items

Ctrl+A

Select all

Ctrl+D

Unselect all
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Appendix D.
Apache License, Version 2.0
TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
1. Definitions.
"License" shall mean the terms and conditions for use, reproduction, and distribution as defined by Sections 1 through 9 of this document.
"Licensor" shall mean the copyright owner or entity authorized by the copyright owner that is granting the License.
"Legal Entity" shall mean the union of the acting entity and all other entities that control, are controlled by, or are under common control with
that entity. For the purposes of this definition, "control" means (i) the power, direct or indirect, to cause the direction or management of such entity, whether by contract or otherwise, or (ii) ownership of fifty percent (50%) or more of the outstanding shares, or (iii) beneficial ownership of
such entity.
"You" (or "Your") shall mean an individual or Legal Entity exercising permissions granted by this License.
"Source" form shall mean the preferred form for making modifications, including but not limited to software source code, documentation source,
and configuration files.
"Object" form shall mean any form resulting from mechanical transformation or translation of a Source form, including but not limited to compiled object code, generated documentation, and conversions to other media types.
"Work" shall mean the work of authorship, whether in Source or Object form, made available under the License, as indicated by a copyright notice that is included in or attached to the work (an example is provided in the Appendix below).
"Derivative Works" shall mean any work, whether in Source or Object form, that is based on (or derived from) the Work and for which the edito rial revisions, annotations, elaborations, or other modifications represent, as a whole, an original work of authorship. For the purposes of this License, Derivative Works shall not include works that remain separable from, or merely link (or bind by name) to the interfaces of, the Work and
Derivative Works thereof.
"Contribution" shall mean any work of authorship, including the original version of the Work and any modifications or additions to that Work or
Derivative Works thereof, that is intentionally submitted to Licensor for inclusion in the Work by the copyright owner or by an individual or Legal Entity authorized to submit on behalf of the copyright owner. For the purposes of this definition, "submitted" means any form of electronic,
verbal, or written communication sent to the Licensor or its representatives, including but not limited to communication on electronic mailing
lists, source code control systems, and issue tracking systems that are managed by, or on behalf of, the Licensor for the purpose of discussing and
improving the Work, but excluding communication that is conspicuously marked or otherwise designated in writing by the copyright owner as
"Not a Contribution."
"Contributor" shall mean Licensor and any individual or Legal Entity on behalf of whom a Contribution has been received by Licensor and subsequently incorporated within the Work.
2. Grant of Copyright License. Subject to the terms and conditions of this License, each Contributor hereby grants to You a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare Derivative Works of, publicly display, publicly
perform, sublicense, and distribute the Work and such Derivative Works in Source or Object form.
3. Grant of Patent License. Subject to the terms and conditions of this License, each Contributor hereby grants to You a perpetual, worldwide,
non-exclusive, no-charge, royalty-free, irrevocable (except as stated in this section) patent license to make, have made, use, offer to sell, sell, import, and otherwise transfer the Work, where such license applies only to those patent claims licensable by such Contributor that are necessarily
infringed by their Contribution(s) alone or by combination of their Contribution(s) with the Work to which such Contribution(s) was submitted.
If You institute patent litigation against any entity (including a cross-claim or counterclaim in a lawsuit) alleging that the Work or a Contribution
incorporated within the Work constitutes direct or contributory patent infringement, then any patent licenses granted to You under this License
for that Work shall terminate as of the date such litigation is filed.
4. Redistribution. You may reproduce and distribute copies of the Work or Derivative Works thereof in any medium, with or without modifications, and in Source or Object form, provided that You meet the following conditions:
a.

You must give any other recipients of the Work or Derivative Works a copy of this License; and

b.

You must cause any modified files to carry prominent notices stating that You changed the files; and

c.

You must retain, in the Source form of any Derivative Works that You distribute, all copyright, patent, trademark, and attribution notices from the Source form of the Work, excluding those notices that do not pertain to any part of the Derivative Works; and

d.

If the Work includes a "NOTICE" text file as part of its distribution, then any Derivative Works that You distribute must include a
readable copy of the attribution notices contained within such NOTICE file, excluding those notices that do not pertain to any part of
the Derivative Works, in at least one of the following places: within a NOTICE text file distributed as part of the Derivative Works;
within the Source form or documentation, if provided along with the Derivative Works; or, within a display generated by the Derivative Works, if and wherever such third-party notices normally appear. The contents of the NOTICE file are for informational purposes
only and do not modify the License. You may add Your own attribution notices within Derivative Works that You distribute, alongside or as an addendum to the NOTICE text from the Work, provided that such additional attribution notices cannot be construed as
modifying the License.
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You may add Your own copyright statement to Your modifications and may provide additional or different license terms and conditions for use,
reproduction, or distribution of Your modifications, or for any such Derivative Works as a whole, provided Your use, reproduction, and distribution of the Work otherwise complies with the conditions stated in this License.
5. Submission of Contributions. Unless You explicitly state otherwise, any Contribution intentionally submitted for inclusion in the Work by
You to the Licensor shall be under the terms and conditions of this License, without any additional terms or conditions. Notwithstanding the
above, nothing herein shall supersede or modify the terms of any separate license agreement you may have executed with Licensor regarding
such Contributions.
6. Trademarks. This License does not grant permission to use the trade names, trademarks, service marks, or product names of the Licensor, except as required for reasonable and customary use in describing the origin of the Work and reproducing the content of the NOTICE file.
7. Disclaimer of Warranty. Unless required by applicable law or agreed to in writing, Licensor provides the Work (and each Contributor provides its Contributions) on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied, including, without limitation, any warranties or conditions of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
PARTICULAR PURPOSE. You are solely responsible for determining the appropriateness of using or redistributing the Work and assume any
risks associated with Your exercise of permissions under this License.
8. Limitation of Liability. In no event and under no legal theory, whether in tort (including negligence), contract, or otherwise, unless required
by applicable law (such as deliberate and grossly negligent acts) or agreed to in writing, shall any Contributor be liable to You for damages, in cluding any direct, indirect, special, incidental, or consequential damages of any character arising as a result of this License or out of the use or
inability to use the Work (including but not limited to damages for loss of goodwill, work stoppage, computer failure or malfunction, or any and
all other commercial damages or losses), even if such Contributor has been advised of the possibility of such damages.
9. Accepting Warranty or Additional Liability. While redistributing the Work or Derivative Works thereof, You may choose to offer, and
charge a fee for, acceptance of support, warranty, indemnity, or other liability obligations and/or rights consistent with this License. However, in
accepting such obligations, You may act only on Your own behalf and on Your sole responsibility, not on behalf of any other Contributor, and
only if You agree to indemnify, defend, and hold each Contributor harmless for any liability incurred by, or claims asserted against, such Contributor by reason of your accepting any such warranty or additional liability.
END OF TERMS AND CONDITIONS
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